0
Fixed

I composed a tweet in Twitter of less than 140 chars. Ritetag thinks this tweet is actually 20-190 chars too long and will not post it.

Essentia 6 years ago updated 6 years ago 7
I composed a tweet in Twitter directly, with 2 Youtube links, and it is at exactly 138 characters in length. I have no trouble posting the entire message to Twitter. However, when I try to copy the tweet into the RiteTag tweet box (the website OR the Chrome extension, doesn't make a difference), it tells me it's approximately 170-190 characters too long. And no matter what I do, if I try to include either of the links and any hashtags at all, even removing the majority of tweet, the best I can do is get it 'down' to about 10-20 chars 'too long'.

At one point, when I tried to copy one of my Youtube links into the Ritetag tweet box again from scratch, it somehow ended up copied about 8 times into the chat box, the other link was suddenly repeating too (though I hadn't touched that one yet). Another time, there appeared a large chunk of white space (as if someone had hit the space bar multiple times after a word, but I hadn't and I couldn't backspace it away). Something is clearly buggy.

I had wanted to track the hashtags and link-clicks for future reference, which I cannot do from inside Twitter directly (as that only shows me the hashtag grading). But apparently I cannot post from Ritetag right now unless it is to say something incredibly short and without links...?

I have not had THIS much difficulty before. This morning I received an email about some update to RiteTag, and now this is a problem. This MUST be a bug?
Under review
Hi,

this is definitely a bug. Thanks for letting us know. We'll look into it right away.
Do you still have somewhere the exact tweet you were trying to send? Thanks.
Feel free to try it now. It should be fixed.
Yeah, unfortunately it doesn't seem fixed on my end... And it doesn't seem to matter what the tweet is, as long as it contains URLs and some combination of non-link words & hashtags. I've not been able to use your built-in post-a-tweet system either through the website dashboard or the Chrome extension for at least 24 hours now.

Since last night (and still today, I just tried), it will append additional a?a?'s to the end of a Youtube link, and when I try to backspace OR delete them, it simply adds several more. To the extreme of 2000+ characters extra before I just stopped and closed the window. 

Also, just now as a test, I tried to remove 2 of the 3 links, and just add a couple extra words or hashtags. If I add those words, and then delete them to try different ones, the character count doesn't go back down with the delete. So when I add a new/different word or hashtag, it simply continues adding characters to my tweet, even though I delete the previous words. So I end up with having to delete the majority of my tweet and still being over the 140 character limit.

I hope that made sense...

If I allow the Chrome extension to auto-compose a tweet based on the website I'm visiting, it seems fine. But if I then edit that auto-composed tweet OR I paste my already-composed tweet from Twitter in, with links, it messes up.


For reference, the tweet I'm currently trying to enter (which appears to be exactly 140 characters in Twitter) so I can keep track of link-clicks and such is (for the record, it still tells me this tweet is about 90 characters 'too long' in the RiteTag box):

"  #gaming RT @quill18 Tropico 5: Max Difficulty Sandbox! P3: http://youtu.be/xmjYiUlIo6U?a | P4: http://youtu.be/YEozdO3DRBo?a | P5: http://youtu.be/mKQhLuU_yEA?a "


Further, this is how it automatically appears when I paste the same above tweet into the Ritetag tweet box:

"  #gaming RT @quill18 Tropico 5: Max Difficulty Sandbox! P3: http://youtu.be/xmjYiUlIo6U?a | P4: http://youtu.be/xmjYiUlIo6U?a | P5: http://youtu.be/mKQhLuU_yEA?a?a
?a?a  "


As you can see, additional a?'s. AND this is what it looks like after I try to hit backspace on those extra a?'s about 4-5 times:

"  #gaming RT @quill18 Tropico 5: Max Difficulty Sandbox! P3: http://youtu.be/xmjYiUlIo6U?a | P4: http://youtu.be/xmjYiUlIo6U?a | P5: http://youtu.be/mKQhLuU_yEA?a?a?a?a?a?a?a?a?a
?a?a?a?a?a?a?a?a?a?  "

If I instead try to place the cursor before the extra a?'s and 'delete' them, this is what it looks like after I hit the delete key 4-5 times:

"  #gaming RT @quill18 Tropico 5: Max Difficulty Sandbox! P3: http://youtu.be/xmjYiUlIo6U?a | P4: http://youtu.be/xmjYiUlIo6U?a | P5: http://youtu.be/mKQhLuU_yEA?a??a??a?a?a?a?a?a??a?a?a??a?a??a?a?a?a?a?a??a?a?a?a?a??a?a?a?a?a?a??a?a?a??a?a??a?a?a?a?a?a??a?a
?a??a??a?a?a?a?a?a??a?a?a??a?a??a?a?a?a?a?a??a?a?a?a?a??a?a?a?a?a?a??a?a?a??a?a??a?a?a?a?a?a??a?a  "

So... as you can see, this is kind of a problem that's rather difficult for me to work around. :)

I've only had a Ritetag account for a few days, but I've been really appreciating it. I was thrilled to get the email about updates yesterday indicating that there should be an even more extensive tweet-grading system that factors in more than just the individual hashtags... but if I can't actually use at all anymore... not so great. :)


Thanks for detailed response. It helped us. Can you try now?
It looks like it's working again now. Thank you for the speedy attention on this! :)

If anything gets weird again, I'll let you know.