0
Completed

I want to unsubscribe, yet I cant because of so much BS - have to log in then the settings do not have a remove me...grrrrr sick of these emails

Douglas Patac 6 years ago updated by RiteTag Support Team 5 years ago 10
This really sucks...sick of emails...
Under review
Douglas,

I am the founder, and the one email I send per week, just informing users of new features and improvements can be easily turned off.  Just log in, and from your name (top right), open Settings. Right at the top is notifications.  You left them turned on, which is why you get the one email/week that sicken you.  Then, click "save" at the bottom.  You wont hear from us again.

Hope this helps,

Saul Fleischman
Founder and CEO
+1
I have done that since the beginning, before I even posted to this forum, it does not work.  There is nothing in the check box now, nor has been.  This is just a bad user experience and a waste of my time.
It worked for your one account, and will for the other.  I just checked, and you still have the @ThePlecoFeeder account set to get notifications.  Kindly sign in to Twitter on that account, go to your settings in RiteTag site, deselect "Receive important updates," save at the bottom, and you wont hear from us.  I see that you did that for @DouglasPatac account, so that one's fine.
+1
Dear Saul,  I did what you said, before I wrote the above post, before you told me how it can be easily turned off, yet the emails keep coming.  Your email subscribe/unsubscribe violate the USA email spam rules.  Please manually remove my account from your database.  Thank you .
We probably have a problem on the admin side.  We'll take care of it immediately, and apologies for the inconvenience.
Just wrote you directly, but in case you don't get that, please login to your other twitter account, then log in to RiteTag (you have a RiteTag account associated with @ThePlecoFeeder) and go to Settings, deselect the notifications box, save at the bottom.  No more emails.
DOES NOT WORK for me.
Whether in Firefox or Chrome, I uncheck the box "Receive important updates" but CANNOT save this setting.
Therefore it stays checked...
Please assess and solve
Thx
Can you please check whether you have selected Person / Company radio button. This may prevent the settings from being saved. 

Best

Michal